Skip to content

← Actionable
Medium, CVSS 5.3

Lack of access control on upoaded files

CVE-2019-12245GHSA-jvx5-rm6q-gx7p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/assets 1.4.4, 1.3.5; silverstripe/framework 4.4.4, 4.3.6, 3.7.4, 3.6.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist silverstripe/assets

    Affected
    >= 1.0.0, < 1.3.5>= 1.4.0, < 1.4.4
    Fixed in
    1.3.5, 1.4.4
  • Packagist silverstripe/framework

    Affected
    < 3.6.8>= 3.7.0, < 3.7.4>= 4.0.0, < 4.3.6>= 4.4.0, < 4.4.4
    Fixed in
    4.3.6, 4.4.4, 3.6.8, 3.7.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2019-12245: 1.37% estimated exploitation activity in the next 30 days; percentile 71.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

SilverStripe through 4.3.3 has incorrect access control for protected files uploaded via Upload::loadIntoFile(). An attacker may be able to guess a filename in silverstripe/assets via the AssetControlExtension.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jvx5-rm6q-gx7p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-12245

Advisory: Lack of access control on upoaded files
IDs: CVE-2019-12245, GHSA-jvx5-rm6q-gx7p
Record: https://patchnext.com/advisories/cve-2019-12245 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: silverstripe/assets 1.4.4, 1.3.5; silverstripe/framework 4.4.4, 4.3.6, 3.7.4, 3.6.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist silverstripe/assets: affected >= 1.0.0, < 1.3.5; >= 1.4.0, < 1.4.4; fixed in 1.3.5, 1.4.4
- Packagist silverstripe/framework: affected < 3.6.8; >= 3.7.0, < 3.7.4; >= 4.0.0, < 4.3.6; >= 4.4.0, < 4.4.4; fixed in 4.3.6, 4.4.4, 3.6.8, 3.7.4

## Suggested inspection (read-only)
- Packagist silverstripe/assets: check the installed version with your package manager.
- Packagist silverstripe/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on silverstripe/assets, silverstripe/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jvx5-rm6q-gx7p (GitHub-reviewed advisory GHSA-jvx5-rm6q-gx7p lists affected ranges: Packagist silverstripe/framework >=0 =3.7.0 =4.0.0 =4.4.0 =1.0.0 =1.4.0 <1.4.4)

Commands are suggestions: review each one before running it.

Loading voting…