Silverstripe Flash Clipboard Reflected XSS
CVE-2019-12205GHSA-rfvw-5848-gxc5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/admin 1.3.5; silverstripe/framework 4.4.4, 4.3.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist silverstripe/admin
- Affected
- < 1.3.5
- Fixed in
- 1.3.5
Packagist silverstripe/framework
- Affected
- >= 3.0.0, < 4.3.5>= 4.4.0-rc1, < 4.4.4
- Fixed in
- 4.4.4, 4.3.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rfvw-5848-gxc5 lists affected ranges: Packagist silverstripe/framework >=3.0.0 =4.4.0-rc1 =0 <1.3.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2019-12205: 0.88% estimated exploitation activity in the next 30 days; percentile 59.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
SilverStripe versions 3.0.0 until 4.3.5 and 4.4.4 are vulnerable to Flash Clipboard Reflected XSS. Versions 4.3.5 and 4.4.4 of silverstripe/framework and version 1.3.5 of silverstripe/admin contain a fix for this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rfvw-5848-gxc5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-12205 Advisory: Silverstripe Flash Clipboard Reflected XSS IDs: CVE-2019-12205, GHSA-rfvw-5848-gxc5 Record: https://patchnext.com/advisories/cve-2019-12205 (revision 1, source checked 26 Oct 2026, 14:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: silverstripe/admin 1.3.5; silverstripe/framework 4.4.4, 4.3.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist silverstripe/admin: affected < 1.3.5; fixed in 1.3.5 - Packagist silverstripe/framework: affected >= 3.0.0, < 4.3.5; >= 4.4.0-rc1, < 4.4.4; fixed in 4.4.4, 4.3.5 ## Suggested inspection (read-only) - Packagist silverstripe/admin: check the installed version with your package manager. - Packagist silverstripe/framework: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on silverstripe/admin, silverstripe/framework. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rfvw-5848-gxc5 (GitHub-reviewed advisory GHSA-rfvw-5848-gxc5 lists affected ranges: Packagist silverstripe/framework >=3.0.0 =4.4.0-rc1 =0 <1.3.5) Commands are suggestions: review each one before running it.
Loading voting…