matrix-sydent and matrix-synapse Use Cryptographically Weak PRNG
CVE-2019-11842GHSA-gwf7-vfjf-wf6x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-sydent 1.0.3; matrix-synapse 0.99.3.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI matrix-sydent
- Affected
- < 1.0.3
- Fixed in
- 1.0.3
PyPI matrix-synapse
- Affected
- < 0.99.3.1
- Fixed in
- 0.99.3.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gwf7-vfjf-wf6x lists affected ranges: PyPI matrix-sydent >=0 =0 <0.99.3.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gwf7-vfjf-wf6x lists affected ranges: PyPI matrix-sydent >=0 =0 <0.99.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2019-11842: 1.80% estimated exploitation activity in the next 30 days; percentile 78.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in Matrix Sydent before 1.0.3 and Synapse before 0.99.3.1. Random number generation is mishandled, which makes it easier for attackers to predict a Sydent authentication token or a Synapse random ID.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-gwf7-vfjf-wf6x
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-gwf7-vfjf-wf6x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-11842 Advisory: matrix-sydent and matrix-synapse Use Cryptographically Weak PRNG IDs: CVE-2019-11842, GHSA-gwf7-vfjf-wf6x Record: https://patchnext.com/advisories/cve-2019-11842 (revision 3, source checked 26 Oct 2026, 13:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: matrix-sydent 1.0.3; matrix-synapse 0.99.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI matrix-sydent: affected < 1.0.3; fixed in 1.0.3 - PyPI matrix-synapse: affected < 0.99.3.1; fixed in 0.99.3.1 ## Suggested inspection (read-only) - `python -m pip show matrix-sydent`: prints the installed version. Run with the environment that serves production active. - `python -m pip show matrix-synapse`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on matrix-sydent, matrix-synapse. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gwf7-vfjf-wf6x (OSV record GHSA-gwf7-vfjf-wf6x lists affected ranges: PyPI matrix-sydent >=0 =0 <0.99.3.1 (fixed)) - Verified: https://github.com/advisories/GHSA-gwf7-vfjf-wf6x (GitHub-reviewed advisory GHSA-gwf7-vfjf-wf6x lists affected ranges: PyPI matrix-sydent >=0 =0 <0.99.3.1) Commands are suggestions: review each one before running it.
Loading voting…