Skip to content

← Actionable
High, CVSS 7.5

Flarum mishandles invalidation of user email tokens

CVE-2019-11514GHSA-g6w5-439m-jhwv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flarum/flarum 0.1.0-beta.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist flarum/flarum

    Affected
    < 0.1.0-beta.8
    Fixed in
    0.1.0-beta.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2019-11514: 1.34% estimated exploitation activity in the next 30 days; percentile 71.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

User/Command/ConfirmEmailHandler.php in Flarum before 0.1.0-beta.8 mishandles invalidation of user email tokens.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g6w5-439m-jhwv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-11514

Advisory: Flarum mishandles invalidation of user email tokens
IDs: CVE-2019-11514, GHSA-g6w5-439m-jhwv
Record: https://patchnext.com/advisories/cve-2019-11514 (revision 1, source checked 26 Oct 2026, 14:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flarum/flarum 0.1.0-beta.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist flarum/flarum: affected < 0.1.0-beta.8; fixed in 0.1.0-beta.8

## Suggested inspection (read-only)
- Packagist flarum/flarum: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flarum/flarum.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g6w5-439m-jhwv (GitHub-reviewed advisory GHSA-g6w5-439m-jhwv lists affected ranges: Packagist flarum/flarum >=0 <0.1.0-beta.8)

Commands are suggestions: review each one before running it.

Loading voting…