Skip to content

← Actionable
Critical, CVSS 9.8

Contao SQL injection in the file manager

CVE-2019-11512GHSA-vq59-x6mq-4wgw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (contao/contao 4.7.5, 4.4.39; contao/core-bundle 4.7.5, 4.4.39), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist contao/contao

    Affected
    >= 4.1.0, < 4.4.39>= 4.5.0, < 4.7.5
    Fixed in
    4.4.39, 4.7.5
  • Packagist contao/core-bundle

    Affected
    >= 4.1.0, < 4.4.39>= 4.5.0, < 4.7.5
    Fixed in
    4.4.39, 4.7.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2019-11512: 1.46% estimated exploitation activity in the next 30 days; percentile 73.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

David Wind, penetration tester with A1 Digital, has discovered that the SQL injection vulnerability originally published under CVE-2017-16558 can still be exploited in the file manager in Contao 4.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vq59-x6mq-4wgw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-11512

Advisory: Contao SQL injection in the file manager
IDs: CVE-2019-11512, GHSA-vq59-x6mq-4wgw
Record: https://patchnext.com/advisories/cve-2019-11512 (revision 1, source checked 26 Oct 2026, 14:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: contao/contao 4.7.5, 4.4.39; contao/core-bundle 4.7.5, 4.4.39. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist contao/contao: affected >= 4.1.0, < 4.4.39; >= 4.5.0, < 4.7.5; fixed in 4.4.39, 4.7.5
- Packagist contao/core-bundle: affected >= 4.1.0, < 4.4.39; >= 4.5.0, < 4.7.5; fixed in 4.4.39, 4.7.5

## Suggested inspection (read-only)
- Packagist contao/contao: check the installed version with your package manager.
- Packagist contao/core-bundle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on contao/contao, contao/core-bundle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vq59-x6mq-4wgw (GitHub-reviewed advisory GHSA-vq59-x6mq-4wgw lists affected ranges: Packagist contao/contao >=4.1.0 =4.5.0 =4.1.0 =4.5.0 <4.7.5)

Commands are suggestions: review each one before running it.

Loading voting…