OpenAPI Tools OpenAPI Generator uses HTTP in various files
CVE-2019-11405GHSA-27j5-2h6r-c9q2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.openapitools:openapi-generator 4.0.0-20190419.052012-560), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.openapitools:openapi-generator
- Affected
- < 4.0.0-20190419.052012-560
- Fixed in
- 4.0.0-20190419.052012-560
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-27j5-2h6r-c9q2 lists affected ranges: Maven org.openapitools:openapi-generator >=0 <4.0.0-20190419.052012-560
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2019-11405: 1.20% estimated exploitation activity in the next 30 days; percentile 68.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
OpenAPI Tools OpenAPI Generator before 4.0.0-20190419.052012-560 uses http:// URLs in various build.gradle, build.gradle.mustache, and build.sbt files, which may have caused insecurely resolved dependencies.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-27j5-2h6r-c9q2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-11405 Advisory: OpenAPI Tools OpenAPI Generator uses HTTP in various files IDs: CVE-2019-11405, GHSA-27j5-2h6r-c9q2 Record: https://patchnext.com/advisories/cve-2019-11405 (revision 1, source checked 26 Oct 2026, 16:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.openapitools:openapi-generator 4.0.0-20190419.052012-560. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.openapitools:openapi-generator: affected < 4.0.0-20190419.052012-560; fixed in 4.0.0-20190419.052012-560 ## Suggested inspection (read-only) - Maven org.openapitools:openapi-generator: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.openapitools:openapi-generator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-27j5-2h6r-c9q2 (GitHub-reviewed advisory GHSA-27j5-2h6r-c9q2 lists affected ranges: Maven org.openapitools:openapi-generator >=0 <4.0.0-20190419.052012-560) Commands are suggestions: review each one before running it.
Loading voting…