Skip to content

← Actionable
High, CVSS 8.6

Insufficiently Protected Credentials in Pivotal Reactor Netty

CVE-2019-11284GHSA-j52r-xc68-q8f4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.projectreactor.netty:reactor-netty 0.8.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2019-11284: 0.90% estimated exploitation activity in the next 30 days; percentile 59.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Pivotal Reactor Netty, versions prior to 0.8.11, passes headers through redirects, including authorization ones. A remote unauthenticated malicious user may gain access to credentials for a different server than they have access to.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j52r-xc68-q8f4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-11284

Advisory: Insufficiently Protected Credentials in Pivotal Reactor Netty
IDs: CVE-2019-11284, GHSA-j52r-xc68-q8f4
Record: https://patchnext.com/advisories/cve-2019-11284 (revision 1, source checked 26 Oct 2026, 16:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.projectreactor.netty:reactor-netty 0.8.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.projectreactor.netty:reactor-netty: affected < 0.8.11; fixed in 0.8.11

## Suggested inspection (read-only)
- Maven io.projectreactor.netty:reactor-netty: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.projectreactor.netty:reactor-netty.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j52r-xc68-q8f4 (GitHub-reviewed advisory GHSA-j52r-xc68-q8f4 lists affected ranges: Maven io.projectreactor.netty:reactor-netty >=0 <0.8.11)

Commands are suggestions: review each one before running it.

Loading voting…