Open Redirect in Spring Security OAuth
CVE-2019-11269GHSA-mmf6-6597-3v6m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.security.oauth:spring-security-oauth 2.3.6.RELEASE, 2.2.5.RELEASE, 2.1.5.RELEASE, 2.0.18.RELEASE), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework.security.oauth:spring-security-oauth
- Affected
- >= 2.0.0.RELEASE, < 2.0.18.RELEASE>= 2.1.0.RELEASE, < 2.1.5.RELEASE>= 2.2.0.RELEASE, < 2.2.5.RELEASE>= 2.3.0.RELEASE, < 2.3.6.RELEASE
- Fixed in
- 2.3.6.RELEASE, 2.1.5.RELEASE, 2.2.5.RELEASE, 2.0.18.RELEASE
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mmf6-6597-3v6m lists affected ranges: Maven org.springframework.security.oauth:spring-security-oauth >=2.0.0.RELEASE =2.1.0.RELEASE =2.2.0.RELEASE =2.3.0.RELEASE <2.3.6.RELEASE
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2019-11269: 8.91% estimated exploitation activity in the next 30 days; percentile 95.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Spring Security OAuth versions 2.3 prior to 2.3.6, 2.2 prior to 2.2.5, 2.1 prior to 2.1.5, and 2.0 prior to 2.0.18, as well as older unsupported versions could be susceptible to an open redirector attack that can leak an authorization code. A malicious user or attacker can craft a request to the authorization endpoint using the authorization code grant type, and specify a manipulated redirection URI via the redirecturi parameter. This can cause the authorization server to redirect the resource owner user-agent to a URI under the control of the attacker with the leaked authorization code.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mmf6-6597-3v6m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-11269 Advisory: Open Redirect in Spring Security OAuth IDs: CVE-2019-11269, GHSA-mmf6-6597-3v6m Record: https://patchnext.com/advisories/cve-2019-11269 (revision 1, source checked 26 Oct 2026, 16:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.springframework.security.oauth:spring-security-oauth 2.3.6.RELEASE, 2.2.5.RELEASE, 2.1.5.RELEASE, 2.0.18.RELEASE. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework.security.oauth:spring-security-oauth: affected >= 2.0.0.RELEASE, < 2.0.18.RELEASE; >= 2.1.0.RELEASE, < 2.1.5.RELEASE; >= 2.2.0.RELEASE, < 2.2.5.RELEASE; >= 2.3.0.RELEASE, < 2.3.6.RELEASE; fixed in 2.3.6.RELEASE, 2.1.5.RELEASE, 2.2.5.RELEASE, 2.0.18.RELEASE ## Suggested inspection (read-only) - Maven org.springframework.security.oauth:spring-security-oauth: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework.security.oauth:spring-security-oauth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mmf6-6597-3v6m (GitHub-reviewed advisory GHSA-mmf6-6597-3v6m lists affected ranges: Maven org.springframework.security.oauth:spring-security-oauth >=2.0.0.RELEASE =2.1.0.RELEASE =2.2.0.RELEASE =2.3.0.RELEASE <2.3.6.RELEASE) Commands are suggestions: review each one before running it.
Loading voting…