Skip to content

← Actionable
Medium, CVSS 6.5

Excessive Platform Resource Consumption within a Loop in Kubernetes

CVE-2019-11254GHSA-wxc4-f4m6-wwqv

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go gopkg.in/yaml.v2

    Affected
    < 2.2.8
    Fixed in
    2.2.8
  • Go github.com/go-yaml/yaml

    Affected
    <= 2.1.0
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2019-11254: 3.16% estimated exploitation activity in the next 30 days; percentile 87.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Kubernetes API Server component in versions 1.1-1.14, and versions prior to 1.15.10, 1.16.7 and 1.17.3 allows an authorized user who sends malicious YAML payloads to cause the kube-apiserver to consume excessive CPU cycles while parsing YAML.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wxc4-f4m6-wwqv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-11254

Advisory: Excessive Platform Resource Consumption within a Loop in Kubernetes
IDs: CVE-2019-11254, GHSA-wxc4-f4m6-wwqv
Record: https://patchnext.com/advisories/cve-2019-11254 (revision 1, source checked 26 Oct 2026, 14:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: gopkg.in/yaml.v2 2.2.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go gopkg.in/yaml.v2: affected < 2.2.8; fixed in 2.2.8
- Go github.com/go-yaml/yaml: affected <= 2.1.0

## Suggested inspection (read-only)
- Go gopkg.in/yaml.v2: check the installed version with your package manager.
- Go github.com/go-yaml/yaml: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gopkg.in/yaml.v2, github.com/go-yaml/yaml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wxc4-f4m6-wwqv (GitHub-reviewed advisory GHSA-wxc4-f4m6-wwqv lists affected ranges: Go gopkg.in/yaml.v2 >=0 =0 <=2.1.0)

Commands are suggestions: review each one before running it.

Loading voting…