Skip to content

← Actionable
High, CVSS 7.5

XML Entity Expansion and Improper Input Validation in Kubernetes API server

CVE-2019-11253GHSA-pmqp-h87c-mr78

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (k8s.io/kubernetes 1.16.2, 1.15.5, 1.14.8, 1.13.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go k8s.io/kubernetes

    Affected
    >= 1.0.0, < 1.13.12>= 1.14.0, < 1.14.8>= 1.15.0, < 1.15.5>= 1.16.0, < 1.16.2
    Fixed in
    1.16.2, 1.15.5, 1.14.8, 1.13.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2019-11253: 25.94% estimated exploitation activity in the next 30 days; percentile 97.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Improper input validation in the Kubernetes API server in versions v1.0-1.12 and versions prior to v1.13.12, v1.14.8, v1.15.5, and v1.16.2 allows authorized users to send malicious YAML or JSON payloads, causing the API server to consume excessive CPU or memory, potentially crashing and becoming unavailable. Prior to v1.14.0, default RBAC policy authorized anonymous users to submit requests that could trigger this vulnerability. Clusters upgraded from a version prior to v1.14.0 keep the more permissive policy by default for backwards compatibility. Specific Go Packages Affected k8s.io/kubernetes/pkg/apiserver

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pmqp-h87c-mr78

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-11253

Advisory: XML Entity Expansion and Improper Input Validation in Kubernetes API server
IDs: CVE-2019-11253, GHSA-pmqp-h87c-mr78
Record: https://patchnext.com/advisories/cve-2019-11253 (revision 1, source checked 26 Oct 2026, 15:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: k8s.io/kubernetes 1.16.2, 1.15.5, 1.14.8, 1.13.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go k8s.io/kubernetes: affected >= 1.0.0, < 1.13.12; >= 1.14.0, < 1.14.8; >= 1.15.0, < 1.15.5; >= 1.16.0, < 1.16.2; fixed in 1.16.2, 1.15.5, 1.14.8, 1.13.12

## Suggested inspection (read-only)
- Go k8s.io/kubernetes: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on k8s.io/kubernetes.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pmqp-h87c-mr78 (GitHub-reviewed advisory GHSA-pmqp-h87c-mr78 lists affected ranges: Go k8s.io/kubernetes >=1.0.0 =1.14.0 =1.15.0 =1.16.0 <1.16.2)

Commands are suggestions: review each one before running it.

Loading voting…