Skip to content

← Actionable
Medium, CVSS 5.7

Kubernetes kubectl cp Vulnerable to Symlink Attack

CVE-2019-11251GHSA-6qfg-8799-r575

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (k8s.io/kubernetes 1.16.0, 1.14.7, 1.13.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go k8s.io/kubernetes

    Affected
    >= 1.13.10, < 1.13.11>= 1.14.6, < 1.14.7>= 1.15.3, < 1.16.0
    Fixed in
    1.14.7, 1.16.0, 1.13.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2019-11251: 2.62% estimated exploitation activity in the next 30 days; percentile 85.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Kubernetes kubectl cp command in versions 1.1-1.12, and versions prior to 1.13.11, 1.14.7, and 1.15.4 allows a combination of two symlinks provided by tar output of a malicious container to place a file outside of the destination directory specified in the kubectl cp invocation. This could be used to allow an attacker to place a nefarious file using a symlink, outside of the destination tree.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6qfg-8799-r575

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-11251

Advisory: Kubernetes kubectl cp Vulnerable to Symlink Attack
IDs: CVE-2019-11251, GHSA-6qfg-8799-r575
Record: https://patchnext.com/advisories/cve-2019-11251 (revision 1, source checked 26 Oct 2026, 14:59 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: k8s.io/kubernetes 1.16.0, 1.14.7, 1.13.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go k8s.io/kubernetes: affected >= 1.13.10, < 1.13.11; >= 1.14.6, < 1.14.7; >= 1.15.3, < 1.16.0; fixed in 1.14.7, 1.16.0, 1.13.11

## Suggested inspection (read-only)
- Go k8s.io/kubernetes: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on k8s.io/kubernetes.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6qfg-8799-r575 (GitHub-reviewed advisory GHSA-6qfg-8799-r575 lists affected ranges: Go k8s.io/kubernetes >=1.13.10 =1.14.6 =1.15.3 <1.16.0)

Commands are suggestions: review each one before running it.

Loading voting…