Skip to content

← Actionable
High, CVSS 8.1

Kubernetes did not effectively clear service account credentials

CVE-2019-11243GHSA-gc2p-g4fg-29vh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (k8s.io/kubernetes 1.13.1, 1.12.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go k8s.io/kubernetes

    Affected
    >= 1.12.0, < 1.12.5>= 1.13.0, < 1.13.1
    Fixed in
    1.12.5, 1.13.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2019-11243: 1.49% estimated exploitation activity in the next 30 days; percentile 74.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Kubernetes v1.12.0-v1.12.4 and v1.13.0, the rest.AnonymousClientConfig() method returns a copy of the provided config, with credentials removed (bearer token, username/password, and client certificate/key data). In the affected versions, rest.AnonymousClientConfig() did not effectively clear service account credentials loaded using rest.InClusterConfig()

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gc2p-g4fg-29vh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-11243

Advisory: Kubernetes did not effectively clear service account credentials
IDs: CVE-2019-11243, GHSA-gc2p-g4fg-29vh
Record: https://patchnext.com/advisories/cve-2019-11243 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: k8s.io/kubernetes 1.13.1, 1.12.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go k8s.io/kubernetes: affected >= 1.12.0, < 1.12.5; >= 1.13.0, < 1.13.1; fixed in 1.12.5, 1.13.1

## Suggested inspection (read-only)
- Go k8s.io/kubernetes: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on k8s.io/kubernetes.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gc2p-g4fg-29vh (GitHub-reviewed advisory GHSA-gc2p-g4fg-29vh lists affected ranges: Go k8s.io/kubernetes >=1.12.0 =1.13.0 <1.13.1)

Commands are suggestions: review each one before running it.

Loading voting…