Skip to content

← Actionable
Critical, CVSS 9.8

Rancher Recreates Default User With Known Password Despite Deletion

CVE-2019-11202GHSA-xh8x-j8h3-m5ph

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2019-11202: 1.60% estimated exploitation activity in the next 30 days; percentile 75.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered that affects the following versions of Rancher: v2.0.0 through v2.0.13, v2.1.0 through v2.1.8, and v2.2.0 through 2.2.1. When Rancher starts for the first time, it creates a default admin user with a well-known password. After initial setup, the Rancher administrator may choose to delete this default admin user. If Rancher is restarted, the default admin user will be recreated with the well-known default password. An attacker could exploit this by logging in with the default admin credentials. This can be mitigated by deactivating the default admin user rather than completing deleting them.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xh8x-j8h3-m5ph

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-11202

Advisory: Rancher Recreates Default User With Known Password Despite Deletion
IDs: CVE-2019-11202, GHSA-xh8x-j8h3-m5ph
Record: https://patchnext.com/advisories/cve-2019-11202 (revision 1, source checked 26 Oct 2026, 15:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: github.com/rancher/rancher 2.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/rancher/rancher: affected >= 2.0.0, <= 2.0.13; >= 2.1.0, <= 2.1.8; >= 2.2.0, < 2.2.2; fixed in 2.2.2

## Suggested inspection (read-only)
- Go github.com/rancher/rancher: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/rancher/rancher.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xh8x-j8h3-m5ph (GitHub-reviewed advisory GHSA-xh8x-j8h3-m5ph lists affected ranges: Go github.com/rancher/rancher >=2.0.0 =2.1.0 =2.2.0 <2.2.2)

Commands are suggestions: review each one before running it.

Loading voting…