Skip to content

← Actionable
Critical, CVSS 9.8

Nokogiri vulnerable to libxslt protection mechanism bypass

CVE-2019-11068GHSA-qxcg-xjjg-66mj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nokogiri 1.10.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems nokogiri

    Affected
    < 1.10.3
    Fixed in
    1.10.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2019-11068: 5.19% estimated exploitation activity in the next 30 days; percentile 92.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A dependency of Nokogiri, libxslt through 1.1.33 allows bypass of a protection mechanism because callers of xsltCheckRead and xsltCheckWrite permit access even upon receiving a -1 error code. xsltCheckRead can return -1 for a crafted URL that is not actually invalid and is subsequently loaded.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qxcg-xjjg-66mj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-11068

Advisory: Nokogiri vulnerable to libxslt protection mechanism bypass
IDs: CVE-2019-11068, GHSA-qxcg-xjjg-66mj
Record: https://patchnext.com/advisories/cve-2019-11068 (revision 1, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nokogiri 1.10.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems nokogiri: affected < 1.10.3; fixed in 1.10.3

## Suggested inspection (read-only)
- RubyGems nokogiri: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nokogiri.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qxcg-xjjg-66mj (GitHub-reviewed advisory GHSA-qxcg-xjjg-66mj lists affected ranges: RubyGems nokogiri >=0 <1.10.3)

Commands are suggestions: review each one before running it.

Loading voting…