Skip to content

← Actionable
Medium, CVSS 6.1amended

Materialize-css vulnerable to Improper Neutralization of Input During Web Page Generation

CVE-2019-11004GHSA-rg3q-jxmp-pvjj

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @materializecss/materialize

    Affected
    < 1.1.0-alpha
    Fixed in
    1.1.0-alpha
  • npm materialize-css

    Affected
    <= 1.0.0
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2019-11004: 0.79% estimated exploitation activity in the next 30 days; percentile 56.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Materialize through 1.0.0, XSS is possible via the Toast feature.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rg3q-jxmp-pvjj

  2. Revision 1 · created ·

    Published from osv record GHSA-rg3q-jxmp-pvjj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-11004

Advisory: Materialize-css vulnerable to Improper Neutralization of Input During Web Page Generation
IDs: CVE-2019-11004, GHSA-rg3q-jxmp-pvjj
Record: https://patchnext.com/advisories/cve-2019-11004 (revision 2, source checked 26 Oct 2026, 12:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: @materializecss/materialize 1.1.0-alpha. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @materializecss/materialize: affected < 1.1.0-alpha; fixed in 1.1.0-alpha
- npm materialize-css: affected <= 1.0.0

## Suggested inspection (read-only)
- `npm ls @materializecss/materialize --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls materialize-css --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @materializecss/materialize, materialize-css.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rg3q-jxmp-pvjj (OSV record GHSA-rg3q-jxmp-pvjj lists affected ranges: npm materialize-css >=0 =0 <1.1.0-alpha (fixed))
- Verified: https://github.com/advisories/GHSA-rg3q-jxmp-pvjj (GitHub-reviewed advisory GHSA-rg3q-jxmp-pvjj lists affected ranges: npm materialize-css >=0 =0 <1.1.0-alpha)

Commands are suggestions: review each one before running it.

Loading voting…