Materialize-css vulnerable to Cross-site Scripting in tooltip component
CVE-2019-11002GHSA-98f7-p5rc-jx67
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @materializecss/materialize
- Affected
- < 1.1.0-alpha
- Fixed in
- 1.1.0-alpha
npm materialize-css
- Affected
- <= 1.0.0
- Fixed in
- no fixed version recorded
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-98f7-p5rc-jx67 lists affected ranges: npm materialize-css >=0 =0 <1.1.0-alpha (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-98f7-p5rc-jx67 lists affected ranges: npm materialize-css >=0 =0 <1.1.0-alpha
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2019-11002: 0.80% estimated exploitation activity in the next 30 days; percentile 56.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
All versions of materialize-css are vulnerable to Cross-Site Scripting. The tooltip component does not sufficiently sanitize user input, allowing an attacker to execute arbitrary JavaScript code if the malicious input is rendered by a user. Recommendation No fix is currently available. Consider using an alternative module until a fix is made available.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-98f7-p5rc-jx67
- Revision 1 · created ·
Published from osv record GHSA-98f7-p5rc-jx67
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-11002 Advisory: Materialize-css vulnerable to Cross-site Scripting in tooltip component IDs: CVE-2019-11002, GHSA-98f7-p5rc-jx67 Record: https://patchnext.com/advisories/cve-2019-11002 (revision 2, source checked 26 Oct 2026, 12:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @materializecss/materialize 1.1.0-alpha. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @materializecss/materialize: affected < 1.1.0-alpha; fixed in 1.1.0-alpha - npm materialize-css: affected <= 1.0.0 ## Suggested inspection (read-only) - `npm ls @materializecss/materialize --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls materialize-css --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @materializecss/materialize, materialize-css. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-98f7-p5rc-jx67 (OSV record GHSA-98f7-p5rc-jx67 lists affected ranges: npm materialize-css >=0 =0 <1.1.0-alpha (fixed)) - Verified: https://github.com/advisories/GHSA-98f7-p5rc-jx67 (GitHub-reviewed advisory GHSA-98f7-p5rc-jx67 lists affected ranges: npm materialize-css >=0 =0 <1.1.0-alpha) Commands are suggestions: review each one before running it.
Loading voting…