Skip to content

← Actionable
High, CVSS 7.5

Improper authentication in Symfony

CVE-2019-10911GHSA-cchx-mfrc-fwqr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 4.2.7, 4.1.12, 3.4.26, 2.8.50, 2.7.51; symfony/security-http 4.2.7, 4.1.12, 3.4.26, 2.8.50, 2.7.51; symfony/security 4.2.7, 4.1.12, 3.4.26, 2.8.50, 2.7.51), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist symfony/symfony

    Affected
    >= 2.7.0, < 2.7.51>= 2.8.0, < 2.8.50>= 3.0.0, < 3.4.26>= 4.0.0, < 4.1.12>= 4.2.0, < 4.2.7
    Fixed in
    2.8.50, 4.1.12, 2.7.51, 4.2.7, 3.4.26
  • Packagist symfony/security-http

    Affected
    >= 2.7.0, < 2.7.51>= 2.8.0, < 2.8.50>= 3.0.0, < 3.4.26>= 4.0.0, < 4.1.12>= 4.2.0, < 4.2.7
    Fixed in
    2.8.50, 4.1.12, 2.7.51, 4.2.7, 3.4.26
  • Packagist symfony/security

    Affected
    >= 2.7.0, < 2.7.51>= 2.8.0, < 2.8.50>= 3.0.0, < 3.4.26>= 4.0.0, < 4.1.12>= 4.2.0, < 4.2.7
    Fixed in
    2.8.50, 4.1.12, 2.7.51, 4.2.7, 3.4.26

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-cchx-mfrc-fwqr lists affected ranges: Packagist symfony/security-http >=2.7.0 =2.8.0 =3.0.0 =4.0.0 =4.2.0 =2.7.0 =2.8.0 =3.0.0 =4.0.0 =4.2.0 =2.7.0 =2.8.0 =3.0.0 =4.0.0 =4.2.0 <4.2.7

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2019-10911: 1.21% estimated exploitation activity in the next 30 days; percentile 68.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, a vulnerability would allow an attacker to authenticate as a privileged user on sites with user registration and remember me login functionality enabled. This is related to symfony/security.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cchx-mfrc-fwqr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-10911

Advisory: Improper authentication in Symfony
IDs: CVE-2019-10911, GHSA-cchx-mfrc-fwqr
Record: https://patchnext.com/advisories/cve-2019-10911 (revision 1, source checked 26 Oct 2026, 14:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 4.2.7, 4.1.12, 3.4.26, 2.8.50, 2.7.51; symfony/security-http 4.2.7, 4.1.12, 3.4.26, 2.8.50, 2.7.51; symfony/security 4.2.7, 4.1.12, 3.4.26, 2.8.50, 2.7.51. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist symfony/symfony: affected >= 2.7.0, < 2.7.51; >= 2.8.0, < 2.8.50; >= 3.0.0, < 3.4.26; >= 4.0.0, < 4.1.12; >= 4.2.0, < 4.2.7; fixed in 2.8.50, 4.1.12, 2.7.51, 4.2.7, 3.4.26
- Packagist symfony/security-http: affected >= 2.7.0, < 2.7.51; >= 2.8.0, < 2.8.50; >= 3.0.0, < 3.4.26; >= 4.0.0, < 4.1.12; >= 4.2.0, < 4.2.7; fixed in 2.8.50, 4.1.12, 2.7.51, 4.2.7, 3.4.26
- Packagist symfony/security: affected >= 2.7.0, < 2.7.51; >= 2.8.0, < 2.8.50; >= 3.0.0, < 3.4.26; >= 4.0.0, < 4.1.12; >= 4.2.0, < 4.2.7; fixed in 2.8.50, 4.1.12, 2.7.51, 4.2.7, 3.4.26

## Suggested inspection (read-only)
- Packagist symfony/symfony: check the installed version with your package manager.
- Packagist symfony/security-http: check the installed version with your package manager.
- Packagist symfony/security: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on symfony/symfony, symfony/security-http, symfony/security.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cchx-mfrc-fwqr (GitHub-reviewed advisory GHSA-cchx-mfrc-fwqr lists affected ranges: Packagist symfony/security-http >=2.7.0 =2.8.0 =3.0.0 =4.0.0 =4.2.0 =2.7.0 =2.8.0 =3.0.0 =4.0.0 =4.2.0 =2.7.0 =2.8.0 =3.0.0 =4.0.0 =4.2.0 <4.2.7)

Commands are suggestions: review each one before running it.

Loading voting…