Skip to content

← Actionable
High, CVSS 8.1

Parsedown Class-Name Injection

CVE-2019-10905GHSA-62m3-fc7f-jpp8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (erusev/parsedown 1.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2019-10905: 1.47% estimated exploitation activity in the next 30 days; percentile 73.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Parsedown before 1.7.2, when safe mode is used and HTML markup is disabled, might allow attackers to execute arbitrary JavaScript code if a script (already running on the affected page) executes the contents of any element with a specific class. This occurs because spaces are permitted in code block infostrings, which interferes with the intended behavior of a single class name beginning with the language- substring.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-62m3-fc7f-jpp8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-10905

Advisory: Parsedown Class-Name Injection
IDs: CVE-2019-10905, GHSA-62m3-fc7f-jpp8
Record: https://patchnext.com/advisories/cve-2019-10905 (revision 1, source checked 26 Oct 2026, 14:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: erusev/parsedown 1.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist erusev/parsedown: affected < 1.7.2; fixed in 1.7.2

## Suggested inspection (read-only)
- Packagist erusev/parsedown: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on erusev/parsedown.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-62m3-fc7f-jpp8 (GitHub-reviewed advisory GHSA-62m3-fc7f-jpp8 lists affected ranges: Packagist erusev/parsedown >=0 <1.7.2)

Commands are suggestions: review each one before running it.

Loading voting…