OpenStack Neutron overlapping security group rules prevents compute node network configuration
CVE-2019-10876GHSA-jr9m-v5qh-mh2j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (neutron 13.0.3, 12.0.6, 11.0.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI neutron
- Affected
- >= 11.0.0, < 11.0.7>= 12.0.0, < 12.0.6>= 13.0.0, < 13.0.3
- Fixed in
- 13.0.3, 12.0.6, 11.0.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jr9m-v5qh-mh2j lists affected ranges: PyPI neutron >=11.0.0 =12.0.0 =13.0.0 <13.0.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jr9m-v5qh-mh2j lists affected ranges: PyPI neutron >=11.0.0 =12.0.0 =13.0.0 <13.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2019-10876: 1.73% estimated exploitation activity in the next 30 days; percentile 77.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in OpenStack Neutron 11.x before 11.0.7, 12.x before 12.0.6, and 13.x before 13.0.3. By creating two security groups with separate/overlapping port ranges, an authenticated user may prevent Neutron from being able to configure networks on any compute nodes where those security groups are present, because of an Open vSwitch (OVS) firewall KeyError. All Neutron deployments utilizing neutron-openvswitch-agent are affected.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jr9m-v5qh-mh2j
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-jr9m-v5qh-mh2j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-10876 Advisory: OpenStack Neutron overlapping security group rules prevents compute node network configuration IDs: CVE-2019-10876, GHSA-jr9m-v5qh-mh2j Record: https://patchnext.com/advisories/cve-2019-10876 (revision 3, source checked 26 Oct 2026, 13:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: neutron 13.0.3, 12.0.6, 11.0.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI neutron: affected >= 11.0.0, < 11.0.7; >= 12.0.0, < 12.0.6; >= 13.0.0, < 13.0.3; fixed in 13.0.3, 12.0.6, 11.0.7 ## Suggested inspection (read-only) - `python -m pip show neutron`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on neutron. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jr9m-v5qh-mh2j (OSV record GHSA-jr9m-v5qh-mh2j lists affected ranges: PyPI neutron >=11.0.0 =12.0.0 =13.0.0 <13.0.3 (fixed)) - Verified: https://github.com/advisories/GHSA-jr9m-v5qh-mh2j (GitHub-reviewed advisory GHSA-jr9m-v5qh-mh2j lists affected ranges: PyPI neutron >=11.0.0 =12.0.0 =13.0.0 <13.0.3) Commands are suggestions: review each one before running it.
Loading voting…