OS Command Injection in devcert-sanscache
CVE-2019-10778GHSA-4gp3-p7ph-x2jr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (devcert-sanscache 0.4.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.4.7
- Fixed in
- 0.4.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4gp3-p7ph-x2jr lists affected ranges: npm devcert-sanscache >=0 <0.4.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4gp3-p7ph-x2jr lists affected ranges: npm devcert-sanscache >=0 <0.4.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-10778: 3.45% estimated exploitation activity in the next 30 days; percentile 89.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
devcert-sanscache before 0.4.7 allows remote attackers to execute arbitrary code or cause a Command Injection via the exec function. The variable commonName controlled by user input is used as part of the exec function without any sanitization.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4gp3-p7ph-x2jr
- Revision 1 · created ·
Published from osv record GHSA-4gp3-p7ph-x2jr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-10778 Advisory: OS Command Injection in devcert-sanscache IDs: CVE-2019-10778, GHSA-4gp3-p7ph-x2jr Record: https://patchnext.com/advisories/cve-2019-10778 (revision 2, source checked 26 Oct 2026, 12:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: devcert-sanscache 0.4.7. A vendor fix does not mean a deployment is fixed. ## Affected components - npm devcert-sanscache: affected < 0.4.7; fixed in 0.4.7 ## Suggested inspection (read-only) - `npm ls devcert-sanscache --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on devcert-sanscache. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4gp3-p7ph-x2jr (OSV record GHSA-4gp3-p7ph-x2jr lists affected ranges: npm devcert-sanscache >=0 <0.4.7 (fixed)) - Verified: https://github.com/advisories/GHSA-4gp3-p7ph-x2jr (GitHub-reviewed advisory GHSA-4gp3-p7ph-x2jr lists affected ranges: npm devcert-sanscache >=0 <0.4.7) Commands are suggestions: review each one before running it.
Loading voting…