Default development error handler in Ratpack is vulnerable to HTML content injection (XSS)
CVE-2019-10770GHSA-r2wf-q3x4-hrv9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.ratpack:ratpack-core 1.7.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.ratpack:ratpack-core
- Affected
- < 1.7.6
- Fixed in
- 1.7.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r2wf-q3x4-hrv9 lists affected ranges: Maven io.ratpack:ratpack-core >=0 <1.7.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2019-10770: 0.86% estimated exploitation activity in the next 30 days; percentile 58.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of Ratpack from 0.9.10 through 1.7.5 are vulnerable to CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') (aka. XSS) in the development error handler. An attacker can utilize this to perform XSS when an exception message contains untrusted data. As a simplistic example: Impact - Cross-Site Scripting Patches This vulnerability has been patched in Ratpack version 1.7.6. Workarounds If you are unable to update your version of Ratpack, we recommend the following workarounds and mitigations. - Ensure that development mode is disabled in production. - Don't use real customer data (ie. untrusted user input) in development. References - Ratpack development mode - Code Patch - a3cbb13 For more information If you have any questions or comments about this advisory: - Open an issue in ratpack/ratpack - Ask in our Slack channel
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r2wf-q3x4-hrv9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-10770 Advisory: Default development error handler in Ratpack is vulnerable to HTML content injection (XSS) IDs: CVE-2019-10770, GHSA-r2wf-q3x4-hrv9 Record: https://patchnext.com/advisories/cve-2019-10770 (revision 1, source checked 26 Oct 2026, 16:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.ratpack:ratpack-core 1.7.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.ratpack:ratpack-core: affected < 1.7.6; fixed in 1.7.6 ## Suggested inspection (read-only) - Maven io.ratpack:ratpack-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.ratpack:ratpack-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r2wf-q3x4-hrv9 (GitHub-reviewed advisory GHSA-r2wf-q3x4-hrv9 lists affected ranges: Maven io.ratpack:ratpack-core >=0 <1.7.6) Commands are suggestions: review each one before running it.
Loading voting…