Arbitrary File Write in iobroker.admin
CVE-2019-10765GHSA-54xj-q58h-9x57
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (iobroker.admin 3.6.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm iobroker.admin
- Affected
- < 3.6.12
- Fixed in
- 3.6.12
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-54xj-q58h-9x57 lists affected ranges: npm iobroker.admin >=0 <3.6.12 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-54xj-q58h-9x57 lists affected ranges: npm iobroker.admin >=0 <3.6.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-10765: 1.71% estimated exploitation activity in the next 30 days; percentile 77.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of iobroker.admin prior to 3.6.12 are vulnerable to Path Traversal. The package fails to restrict access to folders outside of the intended folder in the /log/ route, which may allow attackers to include arbitrary files in the system. An attacker would need to be authenticated to perform the attack but the package has authentication disabled by default. Recommendation Upgrade to version 3.6.12 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-54xj-q58h-9x57
- Revision 1 · created ·
Published from osv record GHSA-54xj-q58h-9x57
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-10765 Advisory: Arbitrary File Write in iobroker.admin IDs: CVE-2019-10765, GHSA-54xj-q58h-9x57 Record: https://patchnext.com/advisories/cve-2019-10765 (revision 2, source checked 26 Oct 2026, 12:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: iobroker.admin 3.6.12. A vendor fix does not mean a deployment is fixed. ## Affected components - npm iobroker.admin: affected < 3.6.12; fixed in 3.6.12 ## Suggested inspection (read-only) - `npm ls iobroker.admin --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on iobroker.admin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-54xj-q58h-9x57 (OSV record GHSA-54xj-q58h-9x57 lists affected ranges: npm iobroker.admin >=0 <3.6.12 (fixed)) - Verified: https://github.com/advisories/GHSA-54xj-q58h-9x57 (GitHub-reviewed advisory GHSA-54xj-q58h-9x57 lists affected ranges: npm iobroker.admin >=0 <3.6.12) Commands are suggestions: review each one before running it.
Loading voting…