Timing attacks might allow practical recovery of the long-term private key
CVE-2019-10764GHSA-mr6r-82x4-f4jj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (simplito/elliptic-php 1.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist simplito/elliptic-php
- Affected
- < 1.0.6
- Fixed in
- 1.0.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mr6r-82x4-f4jj lists affected ranges: Packagist simplito/elliptic-php >=0 <1.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2019-10764: 1.09% estimated exploitation activity in the next 30 days; percentile 65.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In elliptic-php versions priot to 1.0.6, Timing attacks might be possible which can result in practical recovery of the long-term private key generated by the library under certain conditions. Leakage of a bit-length of the scalar during scalar multiplication is possible on an elliptic curve which might allow practical recovery of the long-term private key.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mr6r-82x4-f4jj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-10764 Advisory: Timing attacks might allow practical recovery of the long-term private key IDs: CVE-2019-10764, GHSA-mr6r-82x4-f4jj Record: https://patchnext.com/advisories/cve-2019-10764 (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: simplito/elliptic-php 1.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist simplito/elliptic-php: affected < 1.0.6; fixed in 1.0.6 ## Suggested inspection (read-only) - Packagist simplito/elliptic-php: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on simplito/elliptic-php. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mr6r-82x4-f4jj (GitHub-reviewed advisory GHSA-mr6r-82x4-f4jj lists affected ranges: Packagist simplito/elliptic-php >=0 <1.0.6) Commands are suggestions: review each one before running it.
Loading voting…