Sandbox Breakout / Arbitrary Code Execution in safer-eval
CVE-2019-10760GHSA-hgch-jjmr-gp7w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (safer-eval 1.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm safer-eval
- Affected
- < 1.3.2
- Fixed in
- 1.3.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hgch-jjmr-gp7w lists affected ranges: npm safer-eval >=0 <1.3.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hgch-jjmr-gp7w lists affected ranges: npm safer-eval >=0 <1.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2019-10760: 2.88% estimated exploitation activity in the next 30 days; percentile 86.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of safer-eval before 1.3.2 are vulnerable to Sandbox Escape leading to Remote Code Execution. A payload using constructor properties can escape the sandbox and execute arbitrary code. Recommendation Upgrade to version 1.3.2.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hgch-jjmr-gp7w
- Revision 1 · created ·
Published from osv record GHSA-hgch-jjmr-gp7w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-10760 Advisory: Sandbox Breakout / Arbitrary Code Execution in safer-eval IDs: CVE-2019-10760, GHSA-hgch-jjmr-gp7w Record: https://patchnext.com/advisories/cve-2019-10760 (revision 2, source checked 26 Oct 2026, 12:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: safer-eval 1.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm safer-eval: affected < 1.3.2; fixed in 1.3.2 ## Suggested inspection (read-only) - `npm ls safer-eval --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on safer-eval. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hgch-jjmr-gp7w (OSV record GHSA-hgch-jjmr-gp7w lists affected ranges: npm safer-eval >=0 <1.3.2 (fixed)) - Verified: https://github.com/advisories/GHSA-hgch-jjmr-gp7w (GitHub-reviewed advisory GHSA-hgch-jjmr-gp7w lists affected ranges: npm safer-eval >=0 <1.3.2) Commands are suggestions: review each one before running it.
Loading voting…