Use of Insufficiently Random Values in Apereo CAS
CVE-2019-10754GHSA-g24w-373r-5pxg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apereo.cas:cas-server-support-oauth-core-api 6.1.0-RC5; org.apereo.cas:cas-server-support-shell 6.1.0-RC5; org.apereo.cas:cas-server-support-oidc 6.1.0-RC5; org.apereo.cas:cas-server-core-services-authentication 6.1.0-RC5; org.apereo.cas:cas-server-support-simple-mfa 6.1.0-RC5; 1 more package under Affected packages), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apereo.cas:cas-server-support-oauth-core-api
- Affected
- < 6.1.0-RC5
- Fixed in
- 6.1.0-RC5
Maven org.apereo.cas:cas-server-support-shell
- Affected
- < 6.1.0-RC5
- Fixed in
- 6.1.0-RC5
Maven org.apereo.cas:cas-server-support-oidc
- Affected
- < 6.1.0-RC5
- Fixed in
- 6.1.0-RC5
Maven org.apereo.cas:cas-server-core-services-authentication
- Affected
- < 6.1.0-RC5
- Fixed in
- 6.1.0-RC5
Maven org.apereo.cas:cas-server-support-simple-mfa
- Affected
- < 6.1.0-RC5
- Fixed in
- 6.1.0-RC5
Maven org.apereo.cas:cas-server-core-services-api
- Affected
- < 6.1.0-RC5
- Fixed in
- 6.1.0-RC5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g24w-373r-5pxg lists affected ranges: Maven org.apereo.cas:cas-server-support-simple-mfa >=0 =0 =0 =0 =0 =0 <6.1.0-RC5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2019-10754: 1.77% estimated exploitation activity in the next 30 days; percentile 78.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Multiple classes used within Apereo CAS before release 6.1.0-RC5 makes use of apache commons-lang3 RandomStringUtils for token and ID generation which makes them predictable due to RandomStringUtils PRNG's algorithm not being cryptographically strong.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g24w-373r-5pxg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-10754 Advisory: Use of Insufficiently Random Values in Apereo CAS IDs: CVE-2019-10754, GHSA-g24w-373r-5pxg Record: https://patchnext.com/advisories/cve-2019-10754 (revision 1, source checked 26 Oct 2026, 16:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apereo.cas:cas-server-support-oauth-core-api 6.1.0-RC5; org.apereo.cas:cas-server-support-shell 6.1.0-RC5; org.apereo.cas:cas-server-support-oidc 6.1.0-RC5; org.apereo.cas:cas-server-core-services-authentication 6.1.0-RC5; org.apereo.cas:cas-server-support-simple-mfa 6.1.0-RC5; org.apereo.cas:cas-server-core-services-api 6.1.0-RC5. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apereo.cas:cas-server-support-oauth-core-api: affected < 6.1.0-RC5; fixed in 6.1.0-RC5 - Maven org.apereo.cas:cas-server-support-shell: affected < 6.1.0-RC5; fixed in 6.1.0-RC5 - Maven org.apereo.cas:cas-server-support-oidc: affected < 6.1.0-RC5; fixed in 6.1.0-RC5 - Maven org.apereo.cas:cas-server-core-services-authentication: affected < 6.1.0-RC5; fixed in 6.1.0-RC5 - Maven org.apereo.cas:cas-server-support-simple-mfa: affected < 6.1.0-RC5; fixed in 6.1.0-RC5 - Maven org.apereo.cas:cas-server-core-services-api: affected < 6.1.0-RC5; fixed in 6.1.0-RC5 ## Suggested inspection (read-only) - Maven org.apereo.cas:cas-server-support-oauth-core-api: check the installed version with your package manager. - Maven org.apereo.cas:cas-server-support-shell: check the installed version with your package manager. - Maven org.apereo.cas:cas-server-support-oidc: check the installed version with your package manager. - Maven org.apereo.cas:cas-server-core-services-authentication: check the installed version with your package manager. - Maven org.apereo.cas:cas-server-support-simple-mfa: check the installed version with your package manager. - Maven org.apereo.cas:cas-server-core-services-api: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apereo.cas:cas-server-support-oauth-core-api, org.apereo.cas:cas-server-support-shell, org.apereo.cas:cas-server-support-oidc, org.apereo.cas:cas-server-core-services-authentication, org.apereo.cas:cas-server-support-simple-mfa, org.apereo.cas:cas-server-core-services-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g24w-373r-5pxg (GitHub-reviewed advisory GHSA-g24w-373r-5pxg lists affected ranges: Maven org.apereo.cas:cas-server-support-simple-mfa >=0 =0 =0 =0 =0 =0 <6.1.0-RC5) Commands are suggestions: review each one before running it.
Loading voting…