Jenkins Bumblebee HP ALM Plugin unconditionally disabled SSL/TLS certificate validation
CVE-2019-10444GHSA-qgp8-h5cp-r75r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:bumblebee 4.1.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:bumblebee
- Affected
- <= 4.1.3
- Fixed in
- 4.1.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qgp8-h5cp-r75r lists affected ranges: Maven org.jenkins-ci.plugins:bumblebee >=0 <=4.1.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2019-10444: 0.80% estimated exploitation activity in the next 30 days; percentile 56.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins Bumblebee HP ALM Plugin unconditionally disabled SSL/TLS certificate validation for connections to the HP ALM service. Bumblebee HP ALM Plugin no longer does that. Instead, it now allows users to opt out of certificate validation.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qgp8-h5cp-r75r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-10444 Advisory: Jenkins Bumblebee HP ALM Plugin unconditionally disabled SSL/TLS certificate validation IDs: CVE-2019-10444, GHSA-qgp8-h5cp-r75r Record: https://patchnext.com/advisories/cve-2019-10444 (revision 1, source checked 26 Oct 2026, 16:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:bumblebee 4.1.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:bumblebee: affected <= 4.1.3; fixed in 4.1.4 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:bumblebee: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:bumblebee. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qgp8-h5cp-r75r (GitHub-reviewed advisory GHSA-qgp8-h5cp-r75r lists affected ranges: Maven org.jenkins-ci.plugins:bumblebee >=0 <=4.1.3) Commands are suggestions: review each one before running it.
Loading voting…