Improper Neutralization of Input During Web Page Generation in Jenkins
CVE-2019-10403GHSA-7cjc-xppr-xj6x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.main:jenkins-core 2.197, 2.176.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.main:jenkins-core
- Affected
- <= 2.176.3>= 2.177, <= 2.196
- Fixed in
- 2.197, 2.176.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7cjc-xppr-xj6x lists affected ranges: Maven org.jenkins-ci.main:jenkins-core >=0 =2.177 <=2.196
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2019-10403: 1.03% estimated exploitation activity in the next 30 days; percentile 63.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins 2.196 and earlier, LTS 2.176.3 and earlier did not escape the SCM tag name on the tooltip for SCM tag actions, resulting in a stored XSS vulnerability exploitable by users able to control SCM tag names for these actions.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7cjc-xppr-xj6x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-10403 Advisory: Improper Neutralization of Input During Web Page Generation in Jenkins IDs: CVE-2019-10403, GHSA-7cjc-xppr-xj6x Record: https://patchnext.com/advisories/cve-2019-10403 (revision 1, source checked 26 Oct 2026, 16:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.main:jenkins-core 2.197, 2.176.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.main:jenkins-core: affected <= 2.176.3; >= 2.177, <= 2.196; fixed in 2.197, 2.176.4 ## Suggested inspection (read-only) - Maven org.jenkins-ci.main:jenkins-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.main:jenkins-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7cjc-xppr-xj6x (GitHub-reviewed advisory GHSA-7cjc-xppr-xj6x lists affected ranges: Maven org.jenkins-ci.main:jenkins-core >=0 =2.177 <=2.196) Commands are suggestions: review each one before running it.
Loading voting…