Skip to content

← Actionable
Medium, CVSS 5.4

Improper Encoding or Escaping of Output in Jenkins Configuration as Code Plugin

CVE-2019-10362GHSA-5r6p-p9r6-r326

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.jenkins:configuration-as-code 1.25), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2019-10362: 0.74% estimated exploitation activity in the next 30 days; percentile 54.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Jenkins Configuration as Code Plugin 1.24 and earlier did not escape values resulting in variable interpolation during configuration import when exporting, allowing attackers with permission to change Jenkins system configuration to obtain the values of environment variables.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5r6p-p9r6-r326

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-10362

Advisory: Improper Encoding or Escaping of Output in Jenkins Configuration as Code Plugin
IDs: CVE-2019-10362, GHSA-5r6p-p9r6-r326
Record: https://patchnext.com/advisories/cve-2019-10362 (revision 1, source checked 26 Oct 2026, 16:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.jenkins:configuration-as-code 1.25. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.jenkins:configuration-as-code: affected <= 1.24; fixed in 1.25

## Suggested inspection (read-only)
- Maven io.jenkins:configuration-as-code: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.jenkins:configuration-as-code.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5r6p-p9r6-r326 (GitHub-reviewed advisory GHSA-5r6p-p9r6-r326 lists affected ranges: Maven io.jenkins:configuration-as-code >=0 <=1.24)

Commands are suggestions: review each one before running it.

Loading voting…