Jenkins Maven Release Plugin vulnerable to Cross-site Scripting
CVE-2019-10360GHSA-79rm-f26g-296p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins.m2release:m2release 0.15.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins.m2release:m2release
- Affected
- < 0.15.0
- Fixed in
- 0.15.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-79rm-f26g-296p lists affected ranges: Maven org.jenkins-ci.plugins.m2release:m2release >=0 <0.15.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2019-10360: 0.69% estimated exploitation activity in the next 30 days; percentile 52.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A stored cross site scripting vulnerability in Jenkins Maven Release Plugin 0.14.0 and earlier allowed attackers to inject arbitrary HTML and JavaScript in the plugin-provided web pages in Jenkins. Variables on affected views are now escaped.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-79rm-f26g-296p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-10360 Advisory: Jenkins Maven Release Plugin vulnerable to Cross-site Scripting IDs: CVE-2019-10360, GHSA-79rm-f26g-296p Record: https://patchnext.com/advisories/cve-2019-10360 (revision 1, source checked 26 Oct 2026, 16:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins.m2release:m2release 0.15.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins.m2release:m2release: affected < 0.15.0; fixed in 0.15.0 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins.m2release:m2release: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins.m2release:m2release. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-79rm-f26g-296p (GitHub-reviewed advisory GHSA-79rm-f26g-296p lists affected ranges: Maven org.jenkins-ci.plugins.m2release:m2release >=0 <0.15.0) Commands are suggestions: review each one before running it.
Loading voting…