Plaintext Storage of a Password in Jenkins Configuration as Code Plugin
CVE-2019-10345GHSA-ggmx-pq89-7mcr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.jenkins:configuration-as-code 1.25), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.jenkins:configuration-as-code
- Affected
- < 1.25
- Fixed in
- 1.25
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ggmx-pq89-7mcr lists affected ranges: Maven io.jenkins:configuration-as-code >=0 <1.25
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2019-10345: 0.33% estimated exploitation activity in the next 30 days; percentile 26.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins Configuration as Code Plugin prior to version 1.25 did not treat the proxy password as a secret to be masked when logging or encrypted for export.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-ggmx-pq89-7mcr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-10345 Advisory: Plaintext Storage of a Password in Jenkins Configuration as Code Plugin IDs: CVE-2019-10345, GHSA-ggmx-pq89-7mcr Record: https://patchnext.com/advisories/cve-2019-10345 (revision 1, source checked 26 Oct 2026, 16:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.jenkins:configuration-as-code 1.25. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.jenkins:configuration-as-code: affected < 1.25; fixed in 1.25 ## Suggested inspection (read-only) - Maven io.jenkins:configuration-as-code: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.jenkins:configuration-as-code. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-ggmx-pq89-7mcr (GitHub-reviewed advisory GHSA-ggmx-pq89-7mcr lists affected ranges: Maven io.jenkins:configuration-as-code >=0 <1.25) Commands are suggestions: review each one before running it.
Loading voting…