Missing permission check in Jenkins Ansible Tower Plugin
CVE-2019-10312GHSA-7mvg-cx9c-r6jm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:ansible-tower 0.9.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:ansible-tower
- Affected
- <= 0.9.1
- Fixed in
- 0.9.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7mvg-cx9c-r6jm lists affected ranges: Maven org.jenkins-ci.plugins:ansible-tower >=0 <=0.9.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2019-10312: 1.34% estimated exploitation activity in the next 30 days; percentile 71.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A missing permission check in Jenkins Ansible Tower Plugin 0.9.1 and earlier in the TowerInstallation.TowerInstallationDescriptor#doFillTowerCredentialsIdItems method allowed attackers with Overall/Read permission to enumerate credentials ID of credentials stored in Jenkins.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7mvg-cx9c-r6jm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-10312 Advisory: Missing permission check in Jenkins Ansible Tower Plugin IDs: CVE-2019-10312, GHSA-7mvg-cx9c-r6jm Record: https://patchnext.com/advisories/cve-2019-10312 (revision 1, source checked 26 Oct 2026, 16:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:ansible-tower 0.9.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:ansible-tower: affected <= 0.9.1; fixed in 0.9.2 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:ansible-tower: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:ansible-tower. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7mvg-cx9c-r6jm (GitHub-reviewed advisory GHSA-7mvg-cx9c-r6jm lists affected ranges: Maven org.jenkins-ci.plugins:ansible-tower >=0 <=0.9.1) Commands are suggestions: review each one before running it.
Loading voting…