Skip to content

← Actionable
Medium, CVSS 6.1

Cross-site Scripting in Eclipse Jetty

CVE-2019-10241GHSA-7vx9-xjhr-rw6h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.eclipse.jetty:jetty-server 9.4.16.v20190411, 9.3.26.v20190403, 9.2.27.v20190403), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.eclipse.jetty:jetty-server

    Affected
    <= 9.2.26.v20180806>= 9.3.0, <= 9.3.25.v20180904>= 9.4.0, <= 9.4.15.v20190215
    Fixed in
    9.3.26.v20190403, 9.4.16.v20190411, 9.2.27.v20190403

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2019-10241: 9.37% estimated exploitation activity in the next 30 days; percentile 95.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Eclipse Jetty version 9.2.26 and older, 9.3.25 and older, and 9.4.15 and older, the server is vulnerable to XSS conditions if a remote client USES a specially formatted URL against the DefaultServlet or ResourceHandler that is configured for showing a Listing of directory contents.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7vx9-xjhr-rw6h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-10241

Advisory: Cross-site Scripting in Eclipse Jetty
IDs: CVE-2019-10241, GHSA-7vx9-xjhr-rw6h
Record: https://patchnext.com/advisories/cve-2019-10241 (revision 1, source checked 26 Oct 2026, 16:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.eclipse.jetty:jetty-server 9.4.16.v20190411, 9.3.26.v20190403, 9.2.27.v20190403. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.eclipse.jetty:jetty-server: affected <= 9.2.26.v20180806; >= 9.3.0, <= 9.3.25.v20180904; >= 9.4.0, <= 9.4.15.v20190215; fixed in 9.3.26.v20190403, 9.4.16.v20190411, 9.2.27.v20190403

## Suggested inspection (read-only)
- Maven org.eclipse.jetty:jetty-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.eclipse.jetty:jetty-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7vx9-xjhr-rw6h (GitHub-reviewed advisory GHSA-7vx9-xjhr-rw6h lists affected ranges: Maven org.eclipse.jetty:jetty-server >=0 =9.3.0 =9.4.0 <=9.4.15.v20190215)

Commands are suggestions: review each one before running it.

Loading voting…