Skip to content

← Actionable
Medium, CVSS 5.3amended

Sensitive Data Exposure in parse-server

CVE-2019-1020013GHSA-8w3j-g983-8jh5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 3.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2019-1020013: 1.16% estimated exploitation activity in the next 30 days; percentile 67.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of parse-server prior to 3.6.0 could allow an account enumeration attack via account linking. ParseError.ACCOUNTALREADYLINKED(208) was thrown BEFORE the AuthController checks the password and throws a ParseError.SESSIONMISSING(206) for Insufficient auth. An attacker can guess ids and get information about linked accounts/email addresses. For more information If you have any questions or comments about this advisory, Open an issue in the parse-server Parse Community Vulnerability Disclosure Program

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8w3j-g983-8jh5

  2. Revision 1 · created ·

    Published from osv record GHSA-8w3j-g983-8jh5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-1020013

Advisory: Sensitive Data Exposure in parse-server
IDs: CVE-2019-1020013, GHSA-8w3j-g983-8jh5
Record: https://patchnext.com/advisories/cve-2019-1020013 (revision 2, source checked 26 Oct 2026, 12:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 3.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected < 3.6.0; fixed in 3.6.0

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8w3j-g983-8jh5 (OSV record GHSA-8w3j-g983-8jh5 lists affected ranges: npm parse-server >=0 <3.6.0 (fixed))
- Verified: https://github.com/advisories/GHSA-8w3j-g983-8jh5 (GitHub-reviewed advisory GHSA-8w3j-g983-8jh5 lists affected ranges: npm parse-server >=0 <3.6.0)

Commands are suggestions: review each one before running it.

Loading voting…