Parse Server before v3.4.1 vulnerable to Denial of Service
CVE-2019-1020012GHSA-2479-qvv7-47qq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 3.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- < 3.4.1
- Fixed in
- 3.4.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2479-qvv7-47qq lists affected ranges: npm parse-server >=0 <3.4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2479-qvv7-47qq lists affected ranges: npm parse-server >=0 <3.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2019-1020012: 1.40% estimated exploitation activity in the next 30 days; percentile 72.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact If a POST request is made to /parse/classes/Audience (or other volatile class), any subsuquent POST requests result in an internal server error (500). Patches Afflicted installations will also have to remove the offending collection from their database. Yes, patched in 3.4.1 Workarounds Yes, user can apply: https://github.com/parse-community/parse-server/commit/8709daf698ea69b59268cb66f0f7cee75b52daa5 References Nothing other than this advisory at this time For more information If you have any questions or comments about this advisory: Open an issue in parse-server Email us at security@parseplatform.org
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2479-qvv7-47qq
- Revision 1 · created ·
Published from osv record GHSA-2479-qvv7-47qq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-1020012 Advisory: Parse Server before v3.4.1 vulnerable to Denial of Service IDs: CVE-2019-1020012, GHSA-2479-qvv7-47qq Record: https://patchnext.com/advisories/cve-2019-1020012 (revision 2, source checked 26 Oct 2026, 12:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 3.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected < 3.4.1; fixed in 3.4.1 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2479-qvv7-47qq (OSV record GHSA-2479-qvv7-47qq lists affected ranges: npm parse-server >=0 <3.4.1 (fixed)) - Verified: https://github.com/advisories/GHSA-2479-qvv7-47qq (GitHub-reviewed advisory GHSA-2479-qvv7-47qq lists affected ranges: npm parse-server >=0 <3.4.1) Commands are suggestions: review each one before running it.
Loading voting…