Skip to content

← Actionable
Critical, CVSS 9.8amended

Resource Exhaustion Denial of Service in http-proxy-agent

CVE-2019-10196GHSA-86wf-436m-h424

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (http-proxy-agent 2.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2019-10196: 1.39% estimated exploitation activity in the next 30 days; percentile 72.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was found in http-proxy-agent, prior to version 2.1.0. It was discovered http-proxy-agent passes an auth option to the Buffer constructor without proper sanitization. This could result in a Denial of Service through the usage of all available CPU resources and data exposure through an uninitialized memory leak in setups where an attacker could submit typed input to the auth parameter.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-86wf-436m-h424

  2. Revision 1 · created ·

    Published from osv record GHSA-86wf-436m-h424

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-10196

Advisory: Resource Exhaustion Denial of Service in http-proxy-agent
IDs: CVE-2019-10196, GHSA-86wf-436m-h424
Record: https://patchnext.com/advisories/cve-2019-10196 (revision 2, source checked 26 Oct 2026, 12:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: http-proxy-agent 2.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm http-proxy-agent: affected < 2.1.0; fixed in 2.1.0

## Suggested inspection (read-only)
- `npm ls http-proxy-agent --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on http-proxy-agent.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-86wf-436m-h424 (OSV record GHSA-86wf-436m-h424 lists affected ranges: npm http-proxy-agent >=0 <2.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-86wf-436m-h424 (GitHub-reviewed advisory GHSA-86wf-436m-h424 lists affected ranges: npm http-proxy-agent >=0 <2.1.0)

Commands are suggestions: review each one before running it.

Loading voting…