moodle Improper Access Control
CVE-2019-10188GHSA-92q5-2h76-vgmj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 3.7.1, 3.6.5, 3.5.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- < 3.5.7>= 3.6.0, < 3.6.5>= 3.7.0, < 3.7.1
- Fixed in
- 3.7.1, 3.5.7, 3.6.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-92q5-2h76-vgmj lists affected ranges: Packagist moodle/moodle >=0 =3.6.0 =3.7.0 <3.7.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.0 · CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2019-10188: 0.86% estimated exploitation activity in the next 30 days; percentile 58.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Teachers in a quiz group could modify group overrides for other groups in the same quiz.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-92q5-2h76-vgmj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-10188 Advisory: moodle Improper Access Control IDs: CVE-2019-10188, GHSA-92q5-2h76-vgmj Record: https://patchnext.com/advisories/cve-2019-10188 (revision 1, source checked 26 Oct 2026, 14:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 3.7.1, 3.6.5, 3.5.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected < 3.5.7; >= 3.6.0, < 3.6.5; >= 3.7.0, < 3.7.1; fixed in 3.7.1, 3.5.7, 3.6.5 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-92q5-2h76-vgmj (GitHub-reviewed advisory GHSA-92q5-2h76-vgmj lists affected ranges: Packagist moodle/moodle >=0 =3.6.0 =3.7.0 <3.7.1) Commands are suggestions: review each one before running it.
Loading voting…