Skip to content

← Actionable
High, CVSS 7.2amended

Openstack ironic-inspector has SQL injection vulnerability in node_cache

CVE-2019-10141GHSA-c7fc-cm7p-92r2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ironic-inspector 8.2.1, 8.0.3, 7.2.4, 6.0.3, 5.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ironic-inspector

    Affected
    < 5.0.2>= 5.1.0, < 6.0.3>= 6.1.0, < 7.2.4>= 8.0.0, < 8.0.3>= 8.1.0, < 8.2.1
    Fixed in
    8.2.1, 6.0.3, 8.0.3, 7.2.4, 5.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2019-10141: 2.48% estimated exploitation activity in the next 30 days; percentile 84.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was found in openstack-ironic-inspector all versions excluding 5.0.2, 6.0.3, 7.2.4, 8.0.3 and 8.2.1. A SQL-injection vulnerability was found in openstack-ironic-inspector's nodecache.findnode(). This function makes a SQL query using unfiltered data from a server reporting inspection results (by a POST to the /v1/continue endpoint). Because the API is unauthenticated, the flaw could be exploited by an attacker with access to the network on which ironic-inspector is listening. Because of how ironic-inspector uses the query results, it is unlikely that data could be obtained. However, the attacker could pass malicious data and create a denial of service.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-c7fc-cm7p-92r2

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-c7fc-cm7p-92r2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-10141

Advisory: Openstack ironic-inspector has SQL injection vulnerability in node_cache
IDs: CVE-2019-10141, GHSA-c7fc-cm7p-92r2
Record: https://patchnext.com/advisories/cve-2019-10141 (revision 3, source checked 26 Oct 2026, 13:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ironic-inspector 8.2.1, 8.0.3, 7.2.4, 6.0.3, 5.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ironic-inspector: affected < 5.0.2; >= 5.1.0, < 6.0.3; >= 6.1.0, < 7.2.4; >= 8.0.0, < 8.0.3; >= 8.1.0, < 8.2.1; fixed in 8.2.1, 6.0.3, 8.0.3, 7.2.4, 5.0.2

## Suggested inspection (read-only)
- `python -m pip show ironic-inspector`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ironic-inspector.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c7fc-cm7p-92r2 (OSV record GHSA-c7fc-cm7p-92r2 lists affected ranges: PyPI ironic-inspector >=0 =5.1.0 =6.1.0 =8.0.0 =8.1.0 <8.2.1 (fixed))
- Verified: https://github.com/advisories/GHSA-c7fc-cm7p-92r2 (GitHub-reviewed advisory GHSA-c7fc-cm7p-92r2 lists affected ranges: PyPI ironic-inspector >=0 =5.1.0 =6.1.0 =8.0.0 =8.1.0 <8.2.1)

Commands are suggestions: review each one before running it.

Loading voting…