Skip to content

← Actionable
Medium, CVSS 6.1

Moodle Open Redirect Vulnerability

CVE-2019-10133GHSA-5xp2-rv4h-mm2q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 3.6.4, 3.5.6, 3.4.9, 3.1.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 3.6.0, <= 3.6.3>= 3.5.0, <= 3.5.5>= 3.4.0, <= 3.4.8<= 3.1.17
    Fixed in
    3.5.6, 3.1.18, 3.6.4, 3.4.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2019-10133: 0.90% estimated exploitation activity in the next 30 days; percentile 59.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was found in Moodle before 3.7, 3.6.4, 3.5.6, 3.4.9 and 3.1.18. The form to upload cohorts contained a redirect field, which was not restricted to internal URLs.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5xp2-rv4h-mm2q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-10133

Advisory: Moodle Open Redirect Vulnerability
IDs: CVE-2019-10133, GHSA-5xp2-rv4h-mm2q
Record: https://patchnext.com/advisories/cve-2019-10133 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 3.6.4, 3.5.6, 3.4.9, 3.1.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 3.6.0, <= 3.6.3; >= 3.5.0, <= 3.5.5; >= 3.4.0, <= 3.4.8; <= 3.1.17; fixed in 3.5.6, 3.1.18, 3.6.4, 3.4.9

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5xp2-rv4h-mm2q (GitHub-reviewed advisory GHSA-5xp2-rv4h-mm2q lists affected ranges: Packagist moodle/moodle >=3.6.0 =3.5.0 =3.4.0 =0 <=3.1.17)

Commands are suggestions: review each one before running it.

Loading voting…