Cross site scripting attack in ServiceStack Framework
CVE-2019-1010199GHSA-vcfc-9wcp-j623
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (servicestack 5.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet servicestack
- Affected
- >= 4.5.14, < 5.2.0
- Fixed in
- 5.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vcfc-9wcp-j623 lists affected ranges: NuGet servicestack >=4.5.14 <5.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2019-1010199: 0.89% estimated exploitation activity in the next 30 days; percentile 59.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
ServiceStack ServiceStack Framework 4.5.14 is affected by: Cross Site Scripting (XSS). The impact is: JavaScrpit is reflected in the server response, hence executed by the browser. The component is: the query used in the GET request is prone. The attack vector is: Since there is no server-side validation and If Browser encoding is bypassed, the victim is affected when opening a crafted URL. The fixed version is: 5.2.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vcfc-9wcp-j623
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-1010199 Advisory: Cross site scripting attack in ServiceStack Framework IDs: CVE-2019-1010199, GHSA-vcfc-9wcp-j623 Record: https://patchnext.com/advisories/cve-2019-1010199 (revision 1, source checked 26 Oct 2026, 16:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: servicestack 5.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet servicestack: affected >= 4.5.14, < 5.2.0; fixed in 5.2.0 ## Suggested inspection (read-only) - NuGet servicestack: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on servicestack. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vcfc-9wcp-j623 (GitHub-reviewed advisory GHSA-vcfc-9wcp-j623 lists affected ranges: NuGet servicestack >=4.5.14 <5.2.0) Commands are suggestions: review each one before running it.
Loading voting…