XSS in TinyMCE
CVE-2019-1010091GHSA-c78w-2gw7-gjv3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tinymce 5.2.2, 4.9.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm tinymce
- Affected
- < 4.9.10>= 5.0.0, < 5.2.2
- Fixed in
- 4.9.10, 5.2.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c78w-2gw7-gjv3 lists affected ranges: npm tinymce >=0 =5.0.0 <5.2.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c78w-2gw7-gjv3 lists affected ranges: npm tinymce >=0 =5.0.0 <5.2.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2019-1010091: 1.92% estimated exploitation activity in the next 30 days; percentile 79.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A cross-site scripting (XSS) vulnerability was discovered in: the core parser and media plugin. The vulnerability allowed arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor via the clipboard or APIs. This impacts all users who are using TinyMCE 4.9.9 or lower and TinyMCE 5.2.1 or lower. Patches This vulnerability has been patched in TinyMCE 4.9.10 and 5.2.2 by improved HTML parsing and sanitization logic. Workarounds The workarounds available are: - disable the media plugin and manually sanitize CDATA content (see below) or - upgrade to either TinyMCE 4.9.10 or TinyMCE 5.2.2 Example: Manually strip CDATA elements Acknowledgements Tiny Technologies would like to thank Michał Bentkowski and intivesec for discovering these vulnerabilities. References https://www.tiny.cloud/docs/release-notes/release-notes522/#securityfixes For more information If you have any questions or comments about this advisory: Open an issue in the TinyMCE…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-c78w-2gw7-gjv3
- Revision 1 · created ·
Published from osv record GHSA-c78w-2gw7-gjv3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-1010091 Advisory: XSS in TinyMCE IDs: CVE-2019-1010091, GHSA-c78w-2gw7-gjv3 Record: https://patchnext.com/advisories/cve-2019-1010091 (revision 2, source checked 26 Oct 2026, 12:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tinymce 5.2.2, 4.9.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm tinymce: affected < 4.9.10; >= 5.0.0, < 5.2.2; fixed in 4.9.10, 5.2.2 ## Suggested inspection (read-only) - `npm ls tinymce --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tinymce. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c78w-2gw7-gjv3 (OSV record GHSA-c78w-2gw7-gjv3 lists affected ranges: npm tinymce >=0 =5.0.0 <5.2.2 (fixed)) - Verified: https://github.com/advisories/GHSA-c78w-2gw7-gjv3 (GitHub-reviewed advisory GHSA-c78w-2gw7-gjv3 lists affected ranges: npm tinymce >=0 =5.0.0 <5.2.2) Commands are suggestions: review each one before running it.
Loading voting…