Sandbox bypass in Jenkins Pipeline: Groovy Plugin
CVE-2019-1003030GHSA-r6mc-mrvr-23cr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins.workflow:workflow-cps 2.64), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins.workflow:workflow-cps
- Affected
- < 2.64
- Fixed in
- 2.64
Sources
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2019-1003030 to the Known Exploited Vulnerabilities catalog on 2022-03-25.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2022-03-25).
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r6mc-mrvr-23cr lists affected ranges: Maven org.jenkins-ci.plugins.workflow:workflow-cps >=0 <2.64
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H/E:H
- EPSS
- CVE-2019-1003030: 97.06% estimated exploitation activity in the next 30 days; percentile 99.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A sandbox bypass vulnerability exists in Jenkins Pipeline: Groovy Plugin 2.63 and earlier in pom.xml, src/main/java/org/jenkinsci/plugins/workflow/cps/CpsGroovyShell.java that allows attackers able to control pipeline scripts to execute arbitrary code on the Jenkins master JVM.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r6mc-mrvr-23cr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-1003030 Advisory: Sandbox bypass in Jenkins Pipeline: Groovy Plugin IDs: CVE-2019-1003030, GHSA-r6mc-mrvr-23cr Record: https://patchnext.com/advisories/cve-2019-1003030 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins.workflow:workflow-cps 2.64. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins.workflow:workflow-cps: affected < 2.64; fixed in 2.64 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins.workflow:workflow-cps: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins.workflow:workflow-cps. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2019-1003030 to the Known Exploited Vulnerabilities catalog on 2022-03-25.) - Verified: https://github.com/advisories/GHSA-r6mc-mrvr-23cr (GitHub-reviewed advisory GHSA-r6mc-mrvr-23cr lists affected ranges: Maven org.jenkins-ci.plugins.workflow:workflow-cps >=0 <2.64) Commands are suggestions: review each one before running it.
Loading voting…