Skip to content

← Actionable
Critical, CVSS 9.9Exploited · CISA KEV

Sandbox bypass in Script Security Plugin

CVE-2019-1003029GHSA-xvxq-hq48-xphm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:script-security 1.54), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H/E:H
EPSS
  • CVE-2019-1003029: 74.44% estimated exploitation activity in the next 30 days; percentile 99.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A sandbox bypass vulnerability exists in Jenkins Script Security Plugin 1.53 and earlier in src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/GroovySandbox.java, src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/SecureGroovyScript.java that allows attackers with Overall/Read permission to execute arbitrary code on the Jenkins master JVM.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xvxq-hq48-xphm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-1003029

Advisory: Sandbox bypass in Script Security Plugin
IDs: CVE-2019-1003029, GHSA-xvxq-hq48-xphm
Record: https://patchnext.com/advisories/cve-2019-1003029 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:script-security 1.54. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.jenkins-ci.plugins:script-security: affected < 1.54; fixed in 1.54

## Suggested inspection (read-only)
- Maven org.jenkins-ci.plugins:script-security: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.jenkins-ci.plugins:script-security.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xvxq-hq48-xphm (GitHub-reviewed advisory GHSA-xvxq-hq48-xphm lists affected ranges: Maven org.jenkins-ci.plugins:script-security >=0 <1.54)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2019-1003029 to the Known Exploited Vulnerabilities catalog on 2022-04-25.)

Commands are suggestions: review each one before running it.

Loading voting…