Jenkins Active Directory Plugin Improper certificate validation with StartTLS
CVE-2019-1003009GHSA-2h95-4xw9-m68j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:active-directory 2.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:active-directory
- Affected
- <= 2.10
- Fixed in
- 2.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2h95-4xw9-m68j lists affected ranges: Maven org.jenkins-ci.plugins:active-directory >=0 <=2.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2019-1003009: 0.78% estimated exploitation activity in the next 30 days; percentile 55.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An improper certificate validation vulnerability exists in Jenkins Active Directory Plugin 2.10 and earlier in src/main/java/hudson/plugins/activedirectory/ActiveDirectoryDomain.java, src/main/java/hudson/plugins/activedirectory/ActiveDirectorySecurityRealm.java, src/main/java/hudson/plugins/activedirectory/ActiveDirectoryUnixAuthenticationProvider.java that allows attackers to impersonate the Active Directory server Jenkins connects to for authentication if Jenkins is configured to use StartTLS.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2h95-4xw9-m68j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-1003009 Advisory: Jenkins Active Directory Plugin Improper certificate validation with StartTLS IDs: CVE-2019-1003009, GHSA-2h95-4xw9-m68j Record: https://patchnext.com/advisories/cve-2019-1003009 (revision 1, source checked 26 Oct 2026, 16:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:active-directory 2.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:active-directory: affected <= 2.10; fixed in 2.11 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:active-directory: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:active-directory. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2h95-4xw9-m68j (GitHub-reviewed advisory GHSA-2h95-4xw9-m68j lists affected ranges: Maven org.jenkins-ci.plugins:active-directory >=0 <=2.10) Commands are suggestions: review each one before running it.
Loading voting…