Kubernetes DoS Vulnerability
CVE-2019-1002100GHSA-q4rr-64r9-fwgf
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.11.0, <= 1.11.7>= 1.12.0, <= 1.12.5>= 1.13.0, <= 1.13.3>= 1.0.0, <= 1.10.14
- Fixed in
- 1.13.4, 1.11.8, 1.12.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q4rr-64r9-fwgf lists affected ranges: Go k8s.io/kubernetes >=1.11.0 =1.12.0 =1.13.0 =1.0.0 <=1.10.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2019-1002100: 16.93% estimated exploitation activity in the next 30 days; percentile 97.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In all Kubernetes versions prior to v1.11.8, v1.12.6, and v1.13.4, users that are authorized to make patch requests to the Kubernetes API Server can send a specially crafted patch of type "json-patch" (e.g. kubectl patch --type json or "Content-Type: application/json-patch+json") that consumes excessive resources while processing, causing a Denial of Service on the API Server.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q4rr-64r9-fwgf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-1002100 Advisory: Kubernetes DoS Vulnerability IDs: CVE-2019-1002100, GHSA-q4rr-64r9-fwgf Record: https://patchnext.com/advisories/cve-2019-1002100 (revision 1, source checked 26 Oct 2026, 15:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: k8s.io/kubernetes 1.13.4, 1.12.6, 1.11.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Go k8s.io/kubernetes: affected >= 1.11.0, <= 1.11.7; >= 1.12.0, <= 1.12.5; >= 1.13.0, <= 1.13.3; >= 1.0.0, <= 1.10.14; fixed in 1.13.4, 1.11.8, 1.12.6 ## Suggested inspection (read-only) - Go k8s.io/kubernetes: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on k8s.io/kubernetes. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q4rr-64r9-fwgf (GitHub-reviewed advisory GHSA-q4rr-64r9-fwgf lists affected ranges: Go k8s.io/kubernetes >=1.11.0 =1.12.0 =1.13.0 =1.0.0 <=1.10.14) Commands are suggestions: review each one before running it.
Loading voting…