Moderate severity vulnerability that affects league/commonmark
CVE-2019-10010GHSA-3v43-877x-qgmq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (league/commonmark 0.18.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist league/commonmark
- Affected
- < 0.18.3
- Fixed in
- 0.18.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3v43-877x-qgmq lists affected ranges: Packagist league/commonmark >=0 <0.18.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2019-10010: 1.05% estimated exploitation activity in the next 30 days; percentile 64.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
CVE-2019-10010 Impact In league/commonmark 0.18.2 and below, malicious users can insert double-encoded HTML entities into their Markdown like this: This library would (correctly) unescape the & entity to & during the parsing step. However, the renderer step would fail to properly re-escape the resulting : string, thus producing the following malicious HTML output: Browsers would interpret : as a : character and allow the JS to be executed when the link is clicked. This vulnerability was present in the upstream library this project was forked from and therefore exists in all prior versions of league/commonmark. Solution The new 0.18.3 release mirrors the fix made upstream - we no longer attempt to preserve entities when rendering HTML attributes like href, src, title, etc. The $preserveEntities parameter of Xml::escape() is therefore no longer used internally, so it has been deprecated and marked for removal in the next major release (0.19.0). Credits - Mohit Fawaz for…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3v43-877x-qgmq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-10010 Advisory: Moderate severity vulnerability that affects league/commonmark IDs: CVE-2019-10010, GHSA-3v43-877x-qgmq Record: https://patchnext.com/advisories/cve-2019-10010 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: league/commonmark 0.18.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist league/commonmark: affected < 0.18.3; fixed in 0.18.3 ## Suggested inspection (read-only) - Packagist league/commonmark: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on league/commonmark. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3v43-877x-qgmq (GitHub-reviewed advisory GHSA-3v43-877x-qgmq lists affected ranges: Packagist league/commonmark >=0 <0.18.3) Commands are suggestions: review each one before running it.
Loading voting…