mPDF Unsafe Deserialization
CVE-2019-1000005GHSA-3cwc-m7c2-qr86
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mpdf/mpdf 7.1.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mpdf/mpdf
- Affected
- <= 7.1.7
- Fixed in
- 7.1.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3cwc-m7c2-qr86 lists affected ranges: Packagist mpdf/mpdf >=0 <=7.1.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-1000005: 2.10% estimated exploitation activity in the next 30 days; percentile 81.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
mPDF version 7.1.7 and earlier contains a CWE-502: Deserialization of Untrusted Data vulnerability in getImage() method of Image/ImageProcessor class that can result in Arbitry code execution, file write, etc.. This attack appears to be exploitable via attacker must host crafted image on victim server and trigger generation of pdf file with content <img src="phar://path/to/crafted/image". This vulnerability appears to have been fixed in 7.1.8.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3cwc-m7c2-qr86
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-1000005 Advisory: mPDF Unsafe Deserialization IDs: CVE-2019-1000005, GHSA-3cwc-m7c2-qr86 Record: https://patchnext.com/advisories/cve-2019-1000005 (revision 1, source checked 26 Oct 2026, 14:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mpdf/mpdf 7.1.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mpdf/mpdf: affected <= 7.1.7; fixed in 7.1.8 ## Suggested inspection (read-only) - Packagist mpdf/mpdf: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mpdf/mpdf. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3cwc-m7c2-qr86 (GitHub-reviewed advisory GHSA-3cwc-m7c2-qr86 lists affected ranges: Packagist mpdf/mpdf >=0 <=7.1.7) Commands are suggestions: review each one before running it.
Loading voting…