Apache Tomcat OS Command Injection vulnerability
CVE-2019-0232GHSA-8vmx-qmch-mpqg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat.embed:tomcat-embed-core 9.0.17, 8.5.40, 7.0.94), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat.embed:tomcat-embed-core
- Affected
- >= 8.0.0, < 8.5.40>= 7.0.0, < 7.0.94>= 9.0.0.M1, < 9.0.17
- Fixed in
- 7.0.94, 9.0.17, 8.5.40
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8vmx-qmch-mpqg lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=8.0.0 =7.0.0 =9.0.0.M1 <9.0.17
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-0232: 99.92% estimated exploitation activity in the next 30 days; percentile 99.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When running on Windows with enableCmdLineArguments enabled, the CGI Servlet in Apache Tomcat 9.0.0.M1 to 9.0.17, 8.5.0 to 8.5.39 and 7.0.0 to 7.0.93 is vulnerable to Remote Code Execution due to a bug in the way the JRE passes command line arguments to Windows. The CGI Servlet is disabled by default. The CGI option enableCmdLineArguments is disable by default in Tomcat 9.0.x (and will be disabled by default in all versions in response to this vulnerability). For a detailed explanation of the JRE behaviour, see Markus Wulftange's blog (https://codewhitesec.blogspot.com/2016/02/java-and-command-line-injections-in-windows.html) and this archived MSDN blog (https://web.archive.org/web/20161228144344/https://blogs.msdn.microsoft.com/twistylittlepassagesallalike/2011/04/23/everyone-quotes-command-line-arguments-the-wrong-way/).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8vmx-qmch-mpqg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-0232 Advisory: Apache Tomcat OS Command Injection vulnerability IDs: CVE-2019-0232, GHSA-8vmx-qmch-mpqg Record: https://patchnext.com/advisories/cve-2019-0232 (revision 1, source checked 26 Oct 2026, 16:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat.embed:tomcat-embed-core 9.0.17, 8.5.40, 7.0.94. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 8.0.0, < 8.5.40; >= 7.0.0, < 7.0.94; >= 9.0.0.M1, < 9.0.17; fixed in 7.0.94, 9.0.17, 8.5.40 ## Suggested inspection (read-only) - Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat.embed:tomcat-embed-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8vmx-qmch-mpqg (GitHub-reviewed advisory GHSA-8vmx-qmch-mpqg lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=8.0.0 =7.0.0 =9.0.0.M1 <9.0.17) Commands are suggestions: review each one before running it.
Loading voting…