Improper Control of Generation of Code ('Code Injection') in org.apache.activemq:activemq-client
CVE-2019-0222GHSA-jpv3-g4cc-6vfx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.activemq:activemq-client 5.15.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.activemq:activemq-client
- Affected
- >= 5.0.0, < 5.15.9
- Fixed in
- 5.15.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jpv3-g4cc-6vfx lists affected ranges: Maven org.apache.activemq:activemq-client >=5.0.0 <5.15.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2019-0222: 12.03% estimated exploitation activity in the next 30 days; percentile 96.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Apache ActiveMQ 5.0.0 - 5.15.8, unmarshalling corrupt MQTT frame can lead to broker Out of Memory exception making it unresponsive.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jpv3-g4cc-6vfx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-0222
Advisory: Improper Control of Generation of Code ('Code Injection') in org.apache.activemq:activemq-client
IDs: CVE-2019-0222, GHSA-jpv3-g4cc-6vfx
Record: https://patchnext.com/advisories/cve-2019-0222 (revision 1, source checked 26 Oct 2026, 16:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.activemq:activemq-client 5.15.9. A vendor fix does not mean a deployment is fixed.
## Affected components
- Maven org.apache.activemq:activemq-client: affected >= 5.0.0, < 5.15.9; fixed in 5.15.9
## Suggested inspection (read-only)
- Maven org.apache.activemq:activemq-client: check the installed version with your package manager.
## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.activemq:activemq-client.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://github.com/advisories/GHSA-jpv3-g4cc-6vfx (GitHub-reviewed advisory GHSA-jpv3-g4cc-6vfx lists affected ranges: Maven org.apache.activemq:activemq-client >=5.0.0 <5.15.9)
Commands are suggestions: review each one before running it.Loading voting…