Out-of-bounds read in Apache Thrift
CVE-2019-0210GHSA-jq7p-26h5-w78r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/apache/thrift 0.13.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 0.9.3, < 0.13.0
- Fixed in
- 0.13.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jq7p-26h5-w78r lists affected ranges: Go github.com/apache/thrift >=0.9.3 <0.13.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2019-0210: 6.53% estimated exploitation activity in the next 30 days; percentile 93.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Apache Thrift 0.9.3 to 0.12.0, a server implemented in Go using TJSONProtocol or TSimpleJSONProtocol may panic when feed with invalid input data.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jq7p-26h5-w78r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-0210 Advisory: Out-of-bounds read in Apache Thrift IDs: CVE-2019-0210, GHSA-jq7p-26h5-w78r Record: https://patchnext.com/advisories/cve-2019-0210 (revision 1, source checked 26 Oct 2026, 14:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/apache/thrift 0.13.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/apache/thrift: affected >= 0.9.3, < 0.13.0; fixed in 0.13.0 ## Suggested inspection (read-only) - Go github.com/apache/thrift: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/apache/thrift. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jq7p-26h5-w78r (GitHub-reviewed advisory GHSA-jq7p-26h5-w78r lists affected ranges: Go github.com/apache/thrift >=0.9.3 <0.13.0) Commands are suggestions: review each one before running it.
Loading voting…