Skip to content

← Actionable
Critical, CVSS 9.8

Deserialization of Untrusted Data in Apache Tapestry

CVE-2019-0195GHSA-6mwh-fw4p-75fj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tapestry:tapestry-core 5.4.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2019-0195: 14.02% estimated exploitation activity in the next 30 days; percentile 96.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

By manipulating classpath asset file URLs, an attacker could guess the path to a known file in the classpath and have it downloaded. If the attacker found the file with the value of the tapestry.hmac-passphrase configuration symbol, most probably the webapp's AppModule class, the value of this symbol could be used to craft a Java deserialization attack, thus running malicious injected Java code. The vector would be the t:formdata parameter from the Form component.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6mwh-fw4p-75fj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-0195

Advisory: Deserialization of Untrusted Data in Apache Tapestry
IDs: CVE-2019-0195, GHSA-6mwh-fw4p-75fj
Record: https://patchnext.com/advisories/cve-2019-0195 (revision 1, source checked 26 Oct 2026, 16:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tapestry:tapestry-core 5.4.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tapestry:tapestry-core: affected >= 5.4.0, < 5.4.5; fixed in 5.4.5

## Suggested inspection (read-only)
- Maven org.apache.tapestry:tapestry-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tapestry:tapestry-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6mwh-fw4p-75fj (GitHub-reviewed advisory GHSA-6mwh-fw4p-75fj lists affected ranges: Maven org.apache.tapestry:tapestry-core >=5.4.0 <5.4.5)

Commands are suggestions: review each one before running it.

Loading voting…